Welcome to the Davis launch website.

A compatible Java Runtime Environment (JRE) was not detected on your system. Davis requires 32-bit JRE version 5.0 or above in order to run. If you would like to download and install a JRE now, click here.

After Java is installed, you should be able to run Davis. Click here to try.

If you still cannot launch Davis, you should close all browser windows and then open your browser and try again. This extra step may be needed because some browsers cannot find the new JRE unless they are restarted.

If you still cannot launch Davis after installing the JRE and restarting your browser, please contact Kay Robbins for assistance.